Jumbune
  1. Jumbune
  2. JUM-33

Instrumented Jars doesn't work in Java 1.7 runtimes, hence Jumbune runtime can't be upgraded to 1.7

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Done
    • Affects Version/s: 1.0.0, 1.1.0, 1.1.1, 1.2.0, 1.2.1
    • Fix Version/s: None
    • Component/s: flow debugger
    • Labels:
      None
    • Environment:

      Java 1.7

      Description

      Instrumented code is failing with java.lang.verifyError. Stacks in bytecodes are not being accepted by JRE 1.7

        Activity

        Hide
        Arpan Bhandari added a comment -
        Show
        Arpan Bhandari added a comment - This has been fixed [1] .Please verify [1] . https://github.com/impetus-opensource/jumbune/commit/7aa09591ef2c6fcd5f27810a7d5242e9c7566b50
        Hide
        Mahesh Nair added a comment -

        Verified on build 66

        Show
        Mahesh Nair added a comment - Verified on build 66

          People

          • Assignee:
            Mahesh Nair
            Reporter:
            Mayank
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: